1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Welcome to our Education website, plz like our page facebook to support us. Thank You and wish you good navigation

TD N° 2 : Les boucles et structure alternative

abdelouafiOct 12, 2016

?

Ce TD est il difficile?

  1. oui

    0 vote(s)
    0.0%
  2. non

    2 vote(s)
    100.0%
    1. abdelouafi

      abdelouafi Administrator Staff Member

      Messages:
      184
      Likes Received:
      9
      Trophy Points:
      18
      Joined
      Sep 13, 2016
      TD N° 2

      Programmation en c


      1. Ecrire un algorithme qui demande deux nombres à l’utilisateur et l’informe ensuite si leur produit est négatif ou positif (on laisse de côté le cas où le produit est nul). Attention toutefois : on ne doit pas calculer le produit des deux nombres.

      Traduire l'algorithme en langage c?


      2. Ecrire un algorithme qui demande trois noms à l’utilisateur et l’informe ensuite s’ils sont rangés ou non dans l’ordre alphabétique.

      Traduire l'algorithme en langage c?


      4. Ecrire un programme en c qui demande deux nombres à l’utilisateur et l’informe ensuite si le produit est négatif ou positif (on inclut cette fois le traitement du cas où le produit peut être nul). Attention toutefois, on ne doit pas calculer le produit !


      5. Ecrire un algorithme qui demande l’âge d’un enfant à l’utilisateur. Ensuite, il l’informe de sa catégorie :

      - « Poussin » de 6 à 7 ans

      - « Pupille » de 8 à 9 ans

      - « Minime » de 10 à 11 ans

      - « Cadet » après 12 ans


      6. a partir d’un montant lu, on détermine un montant net par application d’une remise de :

      - 1% si le montant est compris entre 2000 et 5000 Dhs (valeurs comprises)

      - 2 % si le montant est supérieur à 5000 Dhs.

      Ecrire le programme correspondant en c?

      7. Ecrire un programme en c qui permet de calculer la moyenne des notes de 100 étudiants?

      8.Ecrire un algorithme, puis un programme en c, qui demande un nombre de départ, et qui ensuite écrit la table de multiplication de ce nombre, présentée comme suit (cas où l'utilisateur entre le nombre 7) :

      x 1 = 7

      7 x 2 = 14

      7 x 3 = 21



      7 x 10 = 70

      9. Ecrire un algorithme et un programme c qui demande un nombre de départ, et qui calcule la somme des entiers jusqu’à ce nombre. Par exemple, si l’on entre 5, le programme doit calculer :

      1 + 2 + 3 + 4 + 5 = 15

      10. Ecrire un algorithme qui demande successivement 20 nombres à l’utilisateur, et qui lui dise ensuite quel était le plus grand parmi ces 20 nombres :

      Entrez le nombre numéro 1 : 12

      Entrez le nombre numéro 2 : 14



      Entrez le nombre numéro 20 : 6

      Le plus grand de ces nombres est : 14

      Modifiez ensuite l’algorithme pour que le programme affiche de surcroît en quelle position avait été

      saisie ce nombre :

      C’était le nombre numéro 2

      11. Ecrire un algorithme qui :

      - lit d’abord une valeur

      - ensuite il va lire successivement 20 nombres.

      - enfin il va déterminer combien de fois la première valeur a été saisie (sans compter la première

      saisie).

      12. Ecrire un algorithme qui demande un nombre à l’utilisateur, et l’informe ensuite si ce nombre est positif ou négatif (on inclut cette fois le traitement du cas où le nombre vaut zéro).
       

      Attached Files:

      Last edited: Oct 14, 2016
      Loading...
      1. Le programme est :
      Variables a, b : Entier
      Début
      Ecrire “Entrez deux nombres : ”
      Lire (a, b)
      Si a>0 alors
      si b > 0 Alors
      Ecrire “Leur produit est positif”
      sinon
      Ecrire “Leur produit est négatif”
      finsi
      Sinon
      si a<0 alors
      si b > 0 Alors
      Ecrire “Leur produit est négatif”
      sinon
      Ecrire “Leur produit est positif”
      finsi
      sinon
      Ecrire “Leur produit null”
      finsi
      Finsi
      Fin
      2. Le programme est :
      Variables a, b, c : Caractère
      Début
      Ecrire “Entrez successivement trois noms : ”
      Lire a, b, c
      Si a < b et b < c Alors
      Ecrire “Ces noms sont classés alphabétiquement”
      Sinon
      Ecrire “Ces noms ne sont pas classés”
      Finsi
      Fin
      3. Le programme est :
      Variable n : Entier
      Début
      Ecrire “Entrez un nombre : ”
      Lire n
      Si n < 0 Alors
      Ecrire “Ce nombre est négatif”
      SinonSi n = 0 Alors
      Ecrire “Ce nombre est nul”
      Sinon
      Ecrire “Ce nombre est positif”
      Finsi
      Fin
      4. Le programme est :
      Variables m, n : Entier
      Début
      Ecrire “Entrez deux nombres : ”
      Lire m, n
      Si m = 0 OU n = 0 Alors
      Ecrire “Le produit est nul”
      SinonSi (m < 0 ET n < 0) OU (m > 0 ET n > 0) Alors
      Ecrire “Le produit est positif”
      Sinon
      Ecrire “Le produit est négatif”
      Finsi
      Fin
      5. Le programme est :
      Variable age : Entier
      Début
      Ecrire “Entrez l’âge de l’enfant : ”
      Lire age
      Si age >= 12 Alors
      Ecrire “Catégorie Cadet”
      SinonSi age >= 10 Alors
      Ecrire “Catégorie Minime”
      SinonSi age >= 8 Alors
      Ecrire “Catégorie Pupille”
      SinonSi age >= 6 Alors
      Ecrire “Catégorie Poussin”
      Finsi
      Fin
      6. Le programme est :
      Variables montant , taux , remise : Réels
      Début
      Ecrire “Entrez le montant : ”
      Lire montant
      Si montant < 2000 Alors
      taux ← 0
      Sinon
      Si montant ≤ 5000 Alors
      taux ← 1
      Sinon
      taux ← 2
      Fin SI
      Fin Si
      Montant ← montant * (1 – taux / 100)
      Ecrire “Le montant net est : ” , montant
      Fin

Share This Page

Share