1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Welcome to our Education website, plz like our page facebook to support us. Thank You and wish you good navigation

Sablier en Langage C

abdelouafiMay 30, 2017

    1. abdelouafi

      abdelouafi Administrator Staff Member

      Messages:
      183
      Likes Received:
      9
      Trophy Points:
      18
      Joined
      Sep 13, 2016
      Exercice 1:
      Ecrire un programme en C qui permet d'afficher un sablier.
      sablier en c.jpg

      Exercice 2:
      Ecrire un programme en c qui permet d'afficher un triangle:
      triangle langage c.png
       
      Last edited: May 31, 2017
      Loading...
      Exercice 1:

      Code:
      Variable c : Chaîne [ 10 , 10 ]
      Variable i , j , k , b : Entier
      Variable x : Chaîne
      Début
      Répéter
              Afficher ( "donnez votr la taille pair" )
         Saisir ( k )
      Si Modulo ( k , 2 ) <> 0 Alors
                   Afficher ( "la taille doit être pair!" )
              FinSi
         Jusqu'à Modulo ( k , 2 ) = 0
      
         b <- k
         Pour i <- 1 à k
              Pour j <- 1 à k
                   c [ i , j ] <- " "
                   Si i = 1 Alors
                        c [ i , j ] <- "*"
                   FinSi
                   Si i = k Alors
                        c [ i , j ] <- "*"
                   FinSi
                   Si j = b Alors
                        c [ i , j ] <- "*"
                   FinSi
                   Si i = j Alors
                        c [ i , j ] <- "*"
                   FinSi
              FinPour
              b <- b - 1
         FinPour
         Pour i <- 1 à k
              x <- ""
              Pour j <- 1 à k
                   x <- x & c [ i , j ]
              FinPour
              Afficher ( x )
         FinPour
      Fin
      

      Exercice 2:

      Code:
      #include <stdio.h>
      main()
      {
      int n,i,j,k;
      printf("entrer un nombre de lignes");
      scanf("%d",&n);
      for(i=0;i<n;i++)
      {       
          if(i!=n-1)
          {
         
          for(j=0;j<n-1-i;j++)
              {
                  printf(" ");
              }
              for(k=n-1-i;k<n-i;k++)
                  {
                      printf("*");
                  }
                  for(j=n-i;j<n;j++)
                  {
                   printf(" ");
                  }
                 
                  for(k=n;k<n-1+i;k++)
                  {
                      printf(" ");
                  }
                 
                  if (i!=0)
                  {
                      for(j=n-1+i;j<n+i;j++)
                      {
                      printf("*");
                      }
                  }
                  }
                  else
                  {
                          for(j=0;j<n+i;j++) {
                              printf("*");
                          }
                  }
                  printf("\n");
                 
                     
                  }
              }
              

Share This Page

Share